Current supported versions: RC 4.0 and onwards.